All Wheel Junkies All Wheel Drive Enthusiasts Community

Go Back   All Wheel Junkies > AWJunkies General > General Section


Reply
 
Thread Tools

Old July 21st, 2012   #1
toad
Inactive Member
 
Join Date: Sep 18th, 05
Location: mobile, al
Posts: 1,637 | Chats: 239
AWCash: 2,771.45
Vehicle Specs
Default any idea whats wrong with my wrx?

So recently i cleaned the engine bay of my car. i let the car sit for about 6 hours before i drove it, so it could dry and because i washed it at work so i had 6 hours before i got off. when i was driving it i noticed it started breaking up under full boost in 2nd through 5th gear. by breaking up i mean that the car shakes the boost drops and it doesnt accelerate like it should. any idea what i could have got wet that would make it do that, i already checked the MAS swapped it with my brothers and it was good. thanks guys.
  Reply With Quote

Old July 21st, 2012   #2
KINGSKY
Master Tool
 
KINGSKY's Avatar
 
Join Date: Apr 4th, 04
Location: sunny daygo
Posts: 7,539 | Chats: 92205
AWCash: 17,558.85
Vehicle Specs
Default Re: any idea whats wrong with my wrx?

intake? reset teh ecu...
KINGSKY's Sig:RANDi
"make it hot"
Click the image to open in full size.
  Reply With Quote

Old July 21st, 2012   #3
toad
Inactive Member
 
Threadstarter Threadstarter  
Join Date: Sep 18th, 05
Location: mobile, al
Posts: 1,637 | Chats: 239
AWCash: 2,771.45
Vehicle Specs
Default Re: any idea whats wrong with my wrx?

i have a k&n air filter, i cleaned it a few days before all this but forgot a ran out of oil so i didnt put any on, not sure if that would change anything but ill check it out. ecu has been reset and then reflashed back to stock then reflashed back to stage 2.
  Reply With Quote

Old July 22nd, 2012   #4
wjc04wrx
Community Member
 
Join Date: Nov 22nd, 04
Posts: 1,826 | Chats: 45999
AWCash: 6,880.90
Vehicle Specs
Default Re: any idea whats wrong with my wrx?

Did u get any water into the plugs? I would disconnect all the sensor plugs that got wet and dry them out.
  Reply With Quote

Old July 22nd, 2012   #5
toad
Inactive Member
 
Threadstarter Threadstarter  
Join Date: Sep 18th, 05
Location: mobile, al
Posts: 1,637 | Chats: 239
AWCash: 2,771.45
Vehicle Specs
Default Re: any idea whats wrong with my wrx?

Quote:
Originally Posted by wjc04wrx View Post
Did u get any water into the plugs? I would disconnect all the sensor plugs that got wet and dry them out.
im not sure i was pretty careful not to spray at anything that wasn't sheet metal. but ill try what you said...

as far as the intake i switched to a new air filter and it did seem to clean up some of the problem but im still losing boost which i think is my BOV leaking, its crazy, as soon as i get some cash its going into the shop.
  Reply With Quote
Reply

  All Wheel Junkies > AWJunkies General > General Section

Bookmarks

Tags
idea, wrong, wrx


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Doing it wrong! klurejr General Section 3 February 3rd, 2010 11:15 PM



All times are GMT -7. The time now is 05:07 PM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Template-Modifications by TMS
vBCredits v1.4 Copyright ©2007 - 2008, PixelFX Studios
  Copyright ©2000 - 2012 AWNetwork, Inc.
Copyright Notice | License for Reuse | Terms of Use